killistさんノート

killistさんの記録帖

RSS 2.0

mysql用のgem mysql2 (0.3.13)のインストールでエラーが発生する。

こんな感じ。

c:\projects\hoge>bundle update
Fetching gem metadata from https://rubygems.org/...........
Fetching gem metadata from https://rubygems.org/..
Resolving dependencies...
Using rake (10.1.0)
Using i18n (0.6.4)
Using minitest (4.7.4)
Using multi_json (1.7.5)
Using atomic (1.1.9)
Using thread_safe (0.1.0)
Using tzinfo (0.3.37)
Using activesupport (4.0.0.rc1)
Using builder (3.1.4)
Using erubis (2.7.0)
Using rack (1.5.2)
Using rack-test (0.6.2)
Using actionpack (4.0.0.rc1)
Using mime-types (1.23)
Using polyglot (0.3.3)
Using treetop (1.4.12)
Using mail (2.5.4)
Using actionmailer (4.0.0.rc1)
Using activemodel (4.0.0.rc1)
Using activerecord-deprecated_finders (1.0.2)
Using arel (4.0.0)
Using activerecord (4.0.0.rc1)
Using bcrypt-ruby (3.0.1)
Using bundler (1.3.5)
Using coffee-script-source (1.6.2)
Using execjs (1.4.0)
Using coffee-script (2.2.0)
Using thor (0.18.1)
Using railties (4.0.0.rc1)
Using coffee-rails (4.0.0)
Using unf_ext (0.0.6)
Using unf (0.1.1)
Using domain_name (0.5.11)
Using hike (1.2.2)
Using http-cookie (1.0.1)
Using net-http-digest_auth (1.3)
Using net-http-persistent (2.8)
Using nokogiri (1.5.9)
Using ntlm-http (0.1.1)
Using webrobots (0.1.1)
Using mechanize (2.7.1)
Using tilt (1.4.1)
Using sprockets (2.10.0)
Using sprockets-rails (2.0.0.rc4)
Using rails (4.0.0.rc1)
Using i18n_generators (1.2.1)
Using jbuilder (1.0.2)
Using jquery-rails (3.0.0)
Installing mysql2 (0.3.13)
Errno::ENOENT: No such file or directory - F:/SDK/ruby/Ruby193_p385/lib/ruby/gems/1.9.1/gems/mysql2-0.3.13/MIT-LICENSE
An error occurred while installing mysql2 (0.3.13), and Bundler cannot continue.
Make sure that `gem install mysql2 -v '0.3.13'` succeeds before bundling.

ググって見ると次のページがひっかかった。

Installing MySQL2 gem fails while running “bundle install” on Windows

どうやらRedmineのフォーラムなのかな。

記載されてる環境も概ね近い。
Windows 7 Ultimate 64-bitだし、ruby 1.9.3p385とメジャーは同じ。
Railsは違う(ぼくは Rails 4.0.0.rc1 にしちゃってる)が、そこはまぁまぁ。

で読んでみたが、gemのコンパイラの不具合なのかな。
結局、Gemfileにgem ‘mysql2’, ‘= 0.3.11’ と書くことでエラー回避。

killist


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

Category